Clutch Slave Cylinder - VW MK4 5-speed

FTE brand Clutch Slave Cylinder for the MK4 5 speed.

Compatible with the MK4 1.8T, 2.0L, TDI and 12v VR6. Not compatible with the 6 speed/02M.

Compatibility

Vehicle

  • VW MK4 Golf/Jetta 1999.5-2005
    • 1.8T, 5 speed
    • 2.0L, 5 speed
    • TDI, 5 speed
    • 12v VR6, 5 speed
  • FWD Audi TT